EIGRP Configuration With Packet Tracer - www.ipcisco.com : www.ipcisco.com
You can Reach Our "CCNA Lab Courses with Packet Tracer" on Udemy.!!!
cisco-packet-tracer-ccna-adventure-1- cisco-packet-tracer-ccna-adventure-2-
Content Protection by DMCA.com

EIGRP Configuration With Packet Tracer



************************************************************
WouLd YoU LiKe To Learn How to Use PAcket TraceR and PracTice CCNA LAbs
on PaCKet TrAcEr??? Here is My Courses on UDemY!!
CISCO PACKET TRACER HOW TO GUIDE
CISCO PACKET TRACER CCNA LABS ADVENTURE 1
CISCO PACKET TRACER CCNA LABS ADVENTURE 2
************************************************************


EIGRP (Enhanced Interior Gateway Routing Protocol), is a Cisco Proprietary Hybrid Routing Protool. The configuration of EIGRP is similar to other Routing Protocols. In this example, we will configure EIGRP on Packet Tracer.

For our EIGRP example, we will use the below EIGRP topology on Packet Tracer.

You can DOWNLOAD the Packet Tracer example with .pkt format HERE.

For our Packet Tracer EIGRP example, we will use four routers and four PCs.

EIGRP Configuration with Packet Tracer

EIGRP Configuration Topology

IP Configurations For EIGRP Configuration

For our EIGRP configuration, let’s firtly configure IP addresses of routers’ and PCs’ on Packet Tracer.

PC0: 192.168.1.1  255.255.255.0  GW:192.168.1.2
PC1: 192.168.2.1  255.255.255.0  GW:192.168.2.2
PC2: 192.168.3.1  255.255.255.0  GW:192.168.3.2
PC3: 192.168.4.1  255.255.255.0  GW:192.168.4.2

Router0(config)# interface FastEthernet0/0
Router0(config-if)# ip address 192.168.1.2 255.255.255.0
Router0(config-if)# no shutdown
Router0(config-if)# exit
Router0(config)# interface FastEthernet4/0
Router0(config-if)# ip address 10.0.0.1 255.255.255.0
Router0(config-if)# no shutdown
Router0(config-if)# exit
Router0(config)# interface FastEthernet5/0
Router0(config-if)# ip address 20.0.0.1 255.255.255.0
Router0(config-if)# no shutdown
Router0(config-if)# end
Router0# copy running-config startup-config

Router1(config)# interface FastEthernet0/0
Router1(config-if)# ip address 192.168.2.2 255.255.255.0
Router1(config-if)# no shutdown
Router1(config-if)# exit
Router1(config)# interface FastEthernet4/0
Router1(config-if)# ip address 10.0.0.2 255.255.255.0
Router1(config-if)# no shutdown
Router1(config-if)# exit
Router1(config)# interface FastEthernet5/0
Router1(config-if)# ip address 30.0.0.1 255.255.255.0
Router1(config-if)# no shutdown
Router1(config-if)# end
Router1# copy running-config startup-config

Router2(config)# interface FastEthernet0/0
Router2(config-if)# ip address 192.168.3.2 255.255.255.0
Router2(config-if)# no shutdown
Router2(config-if)# exit
Router2(config)# interface FastEthernet4/0
Router2(config-if)# ip address 40.0.0.1 255.255.255.0
Router2(config-if)# no shutdown
Router2(config-if)# exit
Router2(config)# interface FastEthernet5/0
Router2(config-if)# ip address 20.0.0.2 255.255.255.0
Router2(config-if)# no shutdown
Router2(config-if)# end
Router2# copy running-config startup-config

Router3(config)# interface FastEthernet0/0
Router3(config-if)# ip address 192.168.4.2 255.255.255.0
Router3(config-if)# no shutdown
Router3(config-if)# exit
Router3(config)# interface FastEthernet4/0
Router3(config-if)# ip address 40.0.0.2 255.255.255.0
Router3(config-if)# no shutdown
Router3(config-if)# exit
Router3(config)# interface FastEthernet5/0
Router3(config-if)# ip address 30.0.0.2 255.255.255.0
Router3(config-if)# no shutdown
Router3(config-if)# end
Router3# copy running-config startup-config

EIGRP Configuration on Routers


After IP configuration, now it is time to configure EIGRP on each router. For EIGRP configuration, we will use Autonomous System Number. We will use this number with “router eigrp” command. After this command, we will be under router configuration mode. We will add networks that run EIGRP one by one.Lastly we will add “no auto-summary” command to avoid automatic summarization on routing table.

Router0(config)# router eigrp 100
Router0(config-router)# network 192.168.1.0
Router0(config-router)# network 10.0.0.0
Router0(config-router)# network 20.0.0.0
Router0(config-router)# no auto-summary
Router0(config-router)# end
Router0# copy running-config startup-config

Router1(config)# router eigrp 100
Router1(config-router)# network 192.168.2.0
Router1(config-router)# network 10.0.0.0
Router1(config-router)# network 30.0.0.0
Router1(config-router)# no auto-summary
Router1(config-router)# end
Router1# copy running-config startup-config

Router2(config)# router eigrp 100
Router2(config-router)# network 192.168.3.0
Router2(config-router)# network 20.0.0.0
Router2(config-router)# network 40.0.0.0
Router2(config-router)# no auto-summary
Router2(config-router)# end
Router2# copy running-config startup-config

Router3(config)# router eigrp 100
Router3(config-router)# network 192.168.4.0
Router3(config-router)# network 30.0.0.0
Router3(config-router)# network 40.0.0.0
Router3(config-router)# no auto-summary
Router3(config-router)# end
Router3# copy running-config startup-config

EIGRP Configuration Verification


Now let’s verify our EIGRP configuration. Here, we will check only on some routers, not on all of them.

When we use “show ip eigrp ?” command, we can see our eigrp options that we can use on Packet Tracer.

Router#show ip eigrp ?
  interfaces  IP-EIGRP interfaces
  neighbors   IP-EIGRP neighbors
  topology    IP-EIGRP Topology Table
  traffic     IP-EIGRP Traffic Statistics

Here, firstly we will check EIGRP neighbours of Router0 and Router1. We will see EIGRP neighbors with “show ip eigrp neighbors” command.

Router0#show ip eigrp neighbors 
IP-EIGRP neighbors for process 100
H   Address         Interface      Hold Uptime    SRTT   RTO   Q   Seq
                                   (sec)          (ms)        Cnt  Num
0   10.0.0.2        Fa4/0          14   00:14:53  40     1000  0   12
1   20.0.0.2        Fa5/0          12   00:14:53  40     1000  0   11
Router1#show ip eigrp neighbors 
IP-EIGRP neighbors for process 100
H   Address         Interface      Hold Uptime    SRTT   RTO   Q   Seq
                                   (sec)          (ms)        Cnt  Num
0   30.0.0.2        Fa5/0          14   00:16:57  40     1000  0   11
1   10.0.0.1        Fa4/0          13   00:16:57  40     1000  0   13

We can verify the EIGRP interfaces with “show ip eigrp interfaces” command.

Router0#show ip eigrp interfaces 
IP-EIGRP interfaces for process 100

                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Fa4/0              1        0/0      1236       0/10           0           0
Fa5/0              1        0/0      1236       0/10           0           0
Fa0/0              0        0/0      1236       0/10           0           0
Router1#show ip eigrp interfaces 
IP-EIGRP interfaces for process 100

                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Fa4/0              1        0/0      1236       0/10           0           0
Fa5/0              1        0/0      1236       0/10           0           0
Fa0/0              0        0/0      1236       0/10           0           0

We can see the whole Topology Table of Router0 and Router1.

Router0#show ip eigrp topology 
IP-EIGRP Topology Table for AS 100/ID(192.168.1.2)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - Reply status

P 10.0.0.0/24, 1 successors, FD is 28160
         via Connected, FastEthernet4/0
P 20.0.0.0/24, 1 successors, FD is 28160
         via Connected, FastEthernet5/0
P 30.0.0.0/24, 1 successors, FD is 30720
         via 10.0.0.2 (30720/28160), FastEthernet4/0
P 40.0.0.0/8, 1 successors, FD is 30720
         via 20.0.0.2 (30720/28160), FastEthernet5/0
P 192.168.1.0/24, 1 successors, FD is 28160
         via Connected, FastEthernet0/0
P 192.168.2.0/24, 1 successors, FD is 30720
         via 10.0.0.2 (30720/28160), FastEthernet4/0
P 192.168.3.0/24, 1 successors, FD is 30720
         via 20.0.0.2 (30720/28160), FastEthernet5/0
P 192.168.4.0/24, 1 successors, FD is 33280
         via 10.0.0.2 (33280/30720), FastEthernet4/0
Router1#show ip eigrp topology 
IP-EIGRP Topology Table for AS 100/ID(192.168.2.2)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - Reply status

P 10.0.0.0/24, 1 successors, FD is 28160
         via Connected, FastEthernet4/0
P 20.0.0.0/24, 1 successors, FD is 30720
         via 10.0.0.1 (30720/28160), FastEthernet4/0
P 30.0.0.0/24, 1 successors, FD is 28160
         via Connected, FastEthernet5/0
P 40.0.0.0/8, 1 successors, FD is 30720
         via 30.0.0.2 (30720/28160), FastEthernet5/0
P 192.168.1.0/24, 1 successors, FD is 30720
         via 10.0.0.1 (30720/28160), FastEthernet4/0
P 192.168.2.0/24, 1 successors, FD is 28160
         via Connected, FastEthernet0/0
P 192.168.3.0/24, 1 successors, FD is 33280
         via 10.0.0.1 (33280/30720), FastEthernet4/0
P 192.168.4.0/24, 1 successors, FD is 30720
         via 30.0.0.2 (30720/28160), FastEthernet5/0

We can also see the EIGRP traffic statistics with “show ip eigrp traffic” command.

Router0#show ip eigrp traffic 
IP-EIGRP Traffic Statistics for process 100
  Hellos sent/received: 965/644
  Updates sent/received: 16/12
  Queries sent/received: 0/0
  Replies sent/received:  0/0
  Acks sent/received:  5/7
  Input queue high water mark 1, 0 drops
  SIA-Queries sent/received: 0/0
  SIA-Replies sent/received: 0/0
Router#show ip eigrp traffic 
IP-EIGRP Traffic Statistics for process 100
  Hellos sent/received: 1007/671
  Updates sent/received: 14/13
  Queries sent/received: 0/0
  Replies sent/received:  0/0
  Acks sent/received:  10/8
  Input queue high water mark 1, 0 drops
  SIA-Queries sent/received: 0/0
  SIA-Replies sent/received: 0/0

We can check the routing table of Router0. We can see all routing table or we can see onle EIGRP routes.

Router0#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 1 subnets
C       10.0.0.0 is directly connected, FastEthernet4/0
     20.0.0.0/24 is subnetted, 1 subnets
C       20.0.0.0 is directly connected, FastEthernet5/0
     30.0.0.0/24 is subnetted, 1 subnets
D       30.0.0.0 [90/30720] via 10.0.0.2, 00:31:24, FastEthernet4/0
D    40.0.0.0/8 [90/30720] via 20.0.0.2, 00:31:24, FastEthernet5/0
C    192.168.1.0/24 is directly connected, FastEthernet0/0
D    192.168.2.0/24 [90/30720] via 10.0.0.2, 00:31:24, FastEthernet4/0
D    192.168.3.0/24 [90/30720] via 20.0.0.2, 00:31:24, FastEthernet5/0
D    192.168.4.0/24 [90/33280] via 10.0.0.2, 00:31:24, FastEthernet4/0
Router0#show ip route eigrp 
     30.0.0.0/24 is subnetted, 1 subnets
D       30.0.0.0 [90/30720] via 10.0.0.2, 00:31:20, FastEthernet4/0
D    40.0.0.0/8 [90/30720] via 20.0.0.2, 00:31:19, FastEthernet5/0
D    192.168.2.0/24 [90/30720] via 10.0.0.2, 00:31:20, FastEthernet4/0
D    192.168.3.0/24 [90/30720] via 20.0.0.2, 00:31:19, FastEthernet5/0
D    192.168.4.0/24 [90/33280] via 10.0.0.2, 00:31:19, FastEthernet4/0

As you can see above, the routes startind with “D“, are EIGRP routes.

You also see “[90/30720]” values above. Here, the first one is Administrative Distance of EIGRP. It is 90. And the second, 30720, is the metric value.

We can verify the other protocol options like below.

Router0#show ip protocols 

Routing Protocol is "eigrp  100 " 
  Outgoing update filter list for all interfaces is not set 
  Incoming update filter list for all interfaces is not set 
  Default networks flagged in outgoing updates  
  Default networks accepted from incoming updates 
  EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
  EIGRP maximum hopcount 100
  EIGRP maximum metric variance 1
Redistributing: eigrp 100
  Automatic network summarization is not in effect  
  Maximum path: 4
  Routing for Networks:  
     10.0.0.0
     192.168.1.0
     20.0.0.0
  Routing Information Sources:  
    Gateway         Distance      Last Update 
    10.0.0.2        90            0          
    20.0.0.2        90            91         
  Distance: internal 90 external 170

Lastly for verification, we can ping from left top to right bottom, from PC0 to PC3 and vica versa.
Firstly let’s remember the ip addresses of these PCs.

PC0>ipconfig

FastEthernet0 Connection:(default port)

   Link-local IPv6 Address.........: FE80::20A:F3FF:FE86:8B2A
   IP Address......................: 192.168.1.1
   Subnet Mask.....................: 255.255.255.0
   Default Gateway.................: 192.168.1.2
PC1>ipconfig

FastEthernet0 Connection:(default port)

   Link-local IPv6 Address.........: FE80::201:64FF:FE9C:78DB
   IP Address......................: 192.168.4.1
   Subnet Mask.....................: 255.255.255.0
   Default Gateway.................: 192.168.4.2
PC0>ping 192.168.4.1

Pinging 192.168.4.1 with 32 bytes of data:

Reply from 192.168.4.1: bytes=32 time=11ms TTL=125
Reply from 192.168.4.1: bytes=32 time=11ms TTL=125
Reply from 192.168.4.1: bytes=32 time=0ms TTL=125
Reply from 192.168.4.1: bytes=32 time=11ms TTL=125

Ping statistics for 192.168.4.1:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 11ms, Average = 8ms
PC1>ping 192.168.1.1

Pinging 192.168.1.1 with 32 bytes of data:

Reply from 192.168.1.1: bytes=32 time=1ms TTL=125
Reply from 192.168.1.1: bytes=32 time=11ms TTL=125
Reply from 192.168.1.1: bytes=32 time=11ms TTL=125
Reply from 192.168.1.1: bytes=32 time=11ms TTL=125

Ping statistics for 192.168.1.1:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 1ms, Maximum = 11ms, Average = 8ms

And lastly, if we use tracert command to follow the EIGRP route, we will see the below result. We will check tracert result from PC0 to PC3.

PC0>tracert 192.168.4.1

Tracing route to 192.168.4.1 over a maximum of 30 hops: 

  1   1 ms      0 ms      0 ms      192.168.1.2
  2   0 ms      0 ms      0 ms      10.0.0.2
  3   0 ms      0 ms      0 ms      30.0.0.2
  4   11 ms     10 ms     11 ms     192.168.4.1

Trace complete.

As you can see, the EIGRP packets are going through Router1, because the Best Path for that route is this.

Router0#show ip route eigrp 
     30.0.0.0/24 is subnetted, 1 subnets
D       30.0.0.0 [90/30720] via 10.0.0.2, 00:51:31, FastEthernet4/0
D    40.0.0.0/8 [90/30720] via 20.0.0.2, 00:51:31, FastEthernet5/0
D    192.168.2.0/24 [90/30720] via 10.0.0.2, 00:51:31, FastEthernet4/0
D    192.168.3.0/24 [90/30720] via 20.0.0.2, 00:51:31, FastEthernet5/0
D    192.168.4.0/24 [90/33280] via 10.0.0.2, 00:51:31, FastEthernet4/0

You can DOWNLOAD the Packet Tracer example with .pkt format HERE.



************************************************************
WouLd YoU LiKe To Learn How to Use PAcket TraceR and PracTice CCNA LAbs
on PaCKet TrAcEr??? Here is My Courses on UDemY!!
CISCO PACKET TRACER HOW TO GUIDE
CISCO PACKET TRACER CCNA LABS ADVENTURE 1
CISCO PACKET TRACER CCNA LABS ADVENTURE 2
************************************************************

You can download “Packet Tracer” in Tools section.

EIGRP Article Series…
EIGRP – Part 1
EIGRP – Part 2 (EIGRP Tables)
EIGRP – Part 3 (EIGRP Packet Types and Neighborship)
EIGRP – Part 4 (Other EIGRP Properties)

EIGRP Configuration with Packet Tracer

You can check the other Packet Tracer Examples below:

Common Cisco Router Configuration Example on Packet Tracer
Router DHCP Configuration Example on Packet Tracer
VTP Configuration Example on Packet Tracer
VLAN Configuration Example on Packet Tracer
STP Configuration Example on Packet Tracer
RSTP Configuration with Packet Tracer
STP Portfast Configuration with Packet Tracer
Inter VLAN Routing Configuration on Packet Tracer
Switch Virtual Interface (SVI) Configuration with Packet Tracer
BGP Configuration Example on Packet Tracer
Port Security Configuration Example on Packet Tracer
RIP Configuration Example on Packet Tracer
CDP Configuration Example on Packet Tracer
OSPF Area Types Example on Packet Tracer (Standard and Backbone Areas)
OSPF External Routes Example on Packet Tracer
OSPF Area Types Example on Packet Tracer (Stub, NSSA, Totally Stubby, Totally NSSA Areas)

Youn can join OUR Facebook Group with the below links!!!

You can Reach Our "CCNA Lab Courses with Packet Tracer" on Udemy.!!!
cisco-packet-tracer-ccna-adventure-1- cisco-packet-tracer-ccna-adventure-2-



About the Author
Gokhan Kosem is a telecommunation and network engineer. His ambition to IP networks and end-to-end system installation made him to prepare this web-site. By sharing his experiences about various networking protocols beside different system installation experiences and Cisco, Juniper, Alcatel-Lucent devices configurations, he is aimed to be helpful for his collegues in all over the world. He is currently lives in Istanbul, Turkey.

One comment for “EIGRP Configuration With Packet Tracer”

1
Alfred

Need more training

June 9th, 2017 at 21:54

Leave a Reply


Copy Protected by Chetan's WP-Copyprotect.