VLAN - Part 3 (DTP and VLAN Frame Tagging protocols ISL, dot1.q) - www.ipcisco.com : www.ipcisco.com

VLAN – Part 3 (DTP and VLAN Frame Tagging protocols ISL, dot1.q)

Author: gokhankosem, on 04 Oct 15 - Comments Off on VLAN – Part 3 (DTP and VLAN Frame Tagging protocols ISL, dot1.q)
You can Reach Our "CCNA Lab Courses with Packet Tracer" on Udemy.!!!
cisco-packet-tracer-ccna-adventure-1- cisco-packet-tracer-ccna-adventure-2-
Content Protection by DMCA.com

DTP (Dynamic Trunking Protocol)
and VLAN Frame Tagging Protocols
(ISL and dot1.q)

LAN Frame Tagging Protocols (ISL and dot1.q)



There are two types of frame tagging protocols. These are :
– ISL(Inter-Switch Link)
– dot1Q (or IEEE 802.1Q)

These protocols can be configured manually or negotiated by DTP(Dynamic Trunking Protocol). DTP is a Cisco proprietary protocol.

ISL encapsulate the frame with a header (26 bytes) and trailer (4 bytes). So ISL increases the size of a frame 30 bytes. This protocol is a Cisco proprietary protocol and it is not supported on new Cisco devices. ISL support 1000 VLAN on a truk port.

You can configure ISL on Cisco switches like below:

Switch(config)# interface fa0/0
Switch(config-if)# switchport trunk encapsulation isl

Dot1Q (or IEEE 802.1Q) is the industry standart. So with this frame tagging protocol, you can trunk different vendors’ switches. Dot1Q modifies the layer-2 header and add 4-byte VLAN tag into it. Because of this process, the frame CRC value is calculated again. Dot1.q support 4096 VLAN s on a trunk.

You can configure dot1.q on Cisco switches like below:

Switch(config)# interface fa0/0
Switch(config-if)# switchport trunk encapsulation dot1.q

The normal frame size is 1514 bytes. With ISL, this value increate 30 bytes and the frame become giant to other vendor’s switches. But with dot1.q, the frame size become 1514 to 1518. And this value is supported by all other vendors’ swicthes.

vlan frame tagging protocols, ISL and Dot1q

VLAN Frame Tagging Protocols, ISL and Dot1q


Both end must be configure with the same tagging portocol.

To make frame tagging protocol selection, you can use DTP (Dynamic Trunking Protocol). Here, if both ends support both protocol (ISL and dot1.q), then ISL is preferend.

DTP (Dynamic Trunking Protocol)



Trunking in Cisco switches can be configured statically or dynamically. In static mode, the interfaces must be confiugred as trunk manually. In dynamic mode, a specific protocol, DTP (Dynamic Trunking Protocol) is used.


DTP(Dynamic Trunking Protocol) is a trunk negotiation protocol between two Cisco switches. With DTP, directly connected switches determine the interface roles, as a trunk or not.

There are some Trunking modes that can be configured on interface. These Trunking modes, puts an interface in a trunk state imediately or they negotiate with the other end interface on the other switch.

What are these Trunking modes that help DTP?


Trunking Modes



Access : Puts the interface in a permanent nontrunking mode. Even if the other end is in trunking mode.

Switch(config-if)# switchport mode access

Trunk : Puts the interface in a permanent trunking mode. Even if the other end is not in trunking mode.

Switch(config-if)# switchport mode trunk

Dynamic Auto : Puts interface ready to be a trunk if the other end is in trunk or dynamic desirable mode. It is a passive mode. It does not activelly attempt to convert the link to a trunk. The default mode of the recent Cisco switches.

Switch(config-if)# switchport mode dynamic auto

Dynamic Desirable : It is an active mode. It actively attemts to convert the link to a trunk, if the other end in trunk, dynamic auto and dynamic desirable modes. Oldest Cisco switches was in dynamic desirable mode by default.

Switch(config-if)# switchport mode dynamic desirable

Nonegotiate : Prevent sending DTP frames. This command is used after configuring the switch as access or trunk. Here, you are deciding the mode and then you are saying that “do not negotiate about this” with nonegotiate command.

Switch(config-if)# switchport nonegotiate

As a summary, you can check the trunk establishment shapes below:

vlan trunk configuration manual and with dtp

VLAN Trunk Configuration Manual and With DTP

To learn mode about VLAN(Virtual Local Area Network)s, continue with the following posts ;)

VLAN – Part 1
VLAN – Part 2 (VLAN Assignments and VLAN Port Types)
VLAN – Part 3 (VLAN Frame Tagging Protocols, ISL and Dot1.q)
VLAN – Part 4 (How to Configure Cisco VLANs)
VLAN – Part 5 (Packet Tracer VLAN Configuration Example)
VLAN Configuration on Huawei Switches

Private VLANs
Private VLAN Cisco Configuration

What is Protected Port?

You can Reach Our "CCNA Lab Courses with Packet Tracer" on Udemy.!!!
cisco-packet-tracer-ccna-adventure-1- cisco-packet-tracer-ccna-adventure-2-



About the Author
Gokhan Kosem is a telecommunation and network engineer. His ambition to IP networks and end-to-end system installation made him to prepare this web-site. By sharing his experiences about various networking protocols beside different system installation experiences and Cisco, Juniper, Alcatel-Lucent devices configurations, he is aimed to be helpful for his collegues in all over the world. He is currently lives in Istanbul, Turkey.

Comment closed.


Copy Protected by Chetan's WP-Copyprotect.