GRE Tunnel Configuration with Packet Tracer (Cisco)

cisco-gre-configuration-k

Cisco GRE Tunnel Configuration with Packet Tracer

In this confgiuration example, we will see how to configure Cisco GRE (Generic Routing Encapsulation) Tunnel with Packet Tracer. For our GRE Tunnel Configuration example, we will use the below topology and the given IP addresses.


cisco-gre-configuration-k

You can DOWNLOAD the Cisco Packet Tracer example with .pkt format At the End of This Lesson.

Here, we assume that all the IP Configurations have been done and we will focus only GRE Tunell Configuration with Packet Tracer.

Let’s start with Router 0.

GRE Tunnel Configuration

In Router 0, we will create the Tunnel interface and then give this interface an IP Address. After that, we we will define the Tunnel Source, with IP Address or with Interface name. Here, we used Interface name. Lastly, we define the Tunnel Destination IP address.

R0(config)# interface Tunnel 1
R0(config-if)# ip address 50.50.50.1 255.255.255.0
R0(config-if)# tunnel source FastEthernet 0/0
R0(config-if)# tunnel destination 20.0.0.1
R0(config-if)# end
R0# copy running-config startup-config

Now, let’s configure Router 2. We will do the same configuration on Router 2, only IP addresses will change.

R2(config)# interface Tunnel 1
R2(config-if)# ip address 50.50.50.2 255.255.255.0
R2(config-if)# tunnel source FastEthernet 0/0
R2(config-if)# tunnel destination 10.0.0.1
R2(config-if)# end
R2# copy running-config startup-config

GRE Tunnel Static Route

After Tunnel configuration, we need to write a static route on Router 0 and Router 2. Because, the routers needs to know how to reach to the users connected to the other end router. In other words, because of the fact that the other end LAN is not directly connected to the router, it needs routing information and we provide this with a Static Route.

We're Sorry!

Full Access is for only IPCisco Crew...

With IPCisco Membership, You Can Access:

• All Certification Courses (Cisco, Juniper, Nokia and Huawei),
• Thousands of Questions (Lesson Quizes and Special Quiz Section),
• Carieer Consultancy, CV/Resume Check, Career Advice Meeting,
• Cheat Sheets, Job Interview Trainings, Network Tools,
You will be Member of a Big IPCisco Community,
You will Learn Network Lessons with Always,
New And Different Learning Styles!
We are waiting for you!

Lesson tags: cisco packet tracer, GRE
Back to: CCNA > WAN (Wide Area Networks)

CCNA