VPLS (Virtual Private LAN Service) - Part 5 (Cisco Configuration) - www.ipcisco.com : www.ipcisco.com
Content Protection by DMCA.com

Cisco VPLS Configuration Example

In this article we will focus on the VPLS (Virtual Private LAN Service) configuration on Cisco device . We will use the below VPLS (Virtual Private LAN Service) topology for our configuration example.

Cisco VPLS Configuration Example

Cisco VPLS Configuration Example Topology

In this VPLS topology, the devices that we will use are, Cisco Catalyst 6500 Series Switches.
Here, before the configuraton, lets check two term used in commands.

VFI : Virtual Forwarding Instance
VSI : Virtual Switch Instance

Here, VPLS configuration steps will be like below:

1) Configuration of the VSIs(Virtual Switch Instance) and VCs (Virtual Circuits).
2) Configuration of the CE (Customer Equipment) Device Interface.
3) Association of the VC with the VFI (Virtual Forwarding Instance).

We will do these steps one by one for each PE device.

There is an important note before VPLS configuration. As you know split-horizon rule provides broadcast packet loops and isolates the L2 traffic. With the use of “no-split-horizon” command during the VC configuration, we can disble the default L2 split-horizon rule and configure multiple VCs per spoke into the same VFI.

As an example:

Router1(config-vfi)# neighbor 20.20.20.20 encapsulation mpls split-horizon

Let’s see the VPLS (Virtual Private LAN Service) configuration on each device.

Router 1

Router1(config)# l2 vfi PE1_COMPANY_A manual
Router1(config-vfi)# vpn id 100
Router1(config-vfi)# neighbor 20.20.20.20 encapsulation mpls
Router1(config-vfi)# neighbor 30.30.30.30 encapsulation mpls
Router1(config-vfi)# exit

Router1(config)# interface FastEthernet0/0 
Router1(config-if)# switchport
Router1(config-if)# switchport mode dot1qtunnel 
Router1(config-if)# switchport access vlan 100
Router1(config-if)# exit

Router1(config)# interface vlan 100
Router1(config-if)# no ip address
Router1(config-if)# xconnect vfi PE1_COMPANY_A

Router 2

Router2(config)# l2 vfi PE2_COMPANY_A manual
Router2(config-vfi)# vpn id 100
Router2(config-vfi)# neighbor 10.10.10.10 encapsulation mpls
Router2(config-vfi)# neighbor 30.30.30.30 encapsulation mpls
Router2(config-vfi)# exit

Router2(config)# interface FastEthernet0/0 
Router2(config-if)# switchport 
Router2(config-if)# switchport mode dot1qtunnel 
Router2(config-if)# switchport access vlan 100
Router2(config-if)# exit

Router2(config)# interface vlan 100
Router2(config-if)# no ip address
Router2(config-if)# xconnect vfi PE2_COMPANY_A

Router 3

Router3(config)# l2 vfi PE3_COMPANY_A manual
Router3(config-vfi)# vpn id 100
Router3(config-vfi)# neighbor 10.10.10.10 encapsulation mpls
Router3(config-vfi)# neighbor 20.20.20.20 encapsulation mpls
Router3(config-vfi)# exit

Router3(config)# interface FastEthernet0/0 
Router3(config-if)# switchport 
Router3(config-if)# switchport mode dot1qtunnel 
Router3(config-if)# switchport access vlan 100
Router3(config-if)# exit

Router3(config)# interface vlan 100
Router3(config-if)# no ip address
Router3(config-if)# xconnect vfi PE3_COMPANY_A

Verification

Router1# show mpls l2 vc

Router1# show vfi PE1_COMPANY_A 

Router1# show mpls l2 vc det

Here, we have useda basic VPLS (Virtual Private LAN Service) topology and we have done VPLS configuration on these devices.

Other VPLS Articles…

VPLS (Virtual Private LAN Service) – Part 1
VPLS (Virtual Private LAN Service) – Part 2 (Alcatel-Lucent VPLS Configuration)
VPLS (Virtual Private LAN Service) – Part 3 (h-VPLS)
VPLS (Virtual Private LAN Service) – Part 4 (VPLS versus h-VPLS)
VPLS (Virtual Private LAN Service) – Part 5 (Cisco VPLS Configuration)

Youn can join OUR Facebook Group with the below links!!!




About the Author
Gokhan Kosem is a telecommunation and network engineer. His ambition to IP networks and end-to-end system installation made him to prepare this web-site. By sharing his experiences about various networking protocols beside different system installation experiences and Cisco, Juniper, Alcatel-Lucent devices configurations, he is aimed to be helpful for his collegues in all over the world. He is currently lives in Istanbul, Turkey.

Leave a Reply


Copy Protected by Chetan's WP-Copyprotect.