RIP Configuration With Packet Tracer - www.ipcisco.com : www.ipcisco.com
You can Reach Our "CCNA Lab Courses with Packet Tracer" on Udemy.!!!
cisco-packet-tracer-ccna-adventure-1- cisco-packet-tracer-ccna-adventure-2-
Content Protection by DMCA.com

RIP Configuration
With Packet Tracer



************************************************************
WouLd YoU LiKe To Learn How to Use PAcket TraceR and PracTice CCNA LAbs
on PaCKet TrAcEr??? Here is My Courses on UDemY!!
CISCO PACKET TRACER HOW TO GUIDE
CISCO PACKET TRACER CCNA LABS ADVENTURE 1
CISCO PACKET TRACER CCNA LABS ADVENTURE 2
************************************************************

In this article, we will focus on how to configure RIP (Routing Information Protocol) on Cisco Routers. Generally in all network courses, RIP is used to explain routing protocol configuration basically. This is because of its basic configuration.

You can DOWNLOAD the Packet Tracer example with .pkt format HERE.

For our example, we will use the following basic topology:

RIP (Routing Information Protocol)

RIP Example Topology

With this topology, the IP addresses are configured. We will pass the configuration of IP addresses and continue only the routing protocol, RIP configuration.

Before the configuration of RIP, let’s check the routing table of RouterA.

RouterA#show ip route 
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/30 is subnetted, 1 subnets
C       10.10.10.0 is directly connected, FastEthernet0/0
     20.0.0.0/30 is subnetted, 1 subnets
C       20.20.20.0 is directly connected, FastEthernet0/1

RouterA#show ip protocols

RouterA#show ip int brief 
Interface              IP-Address      OK? Method Status                Protocol
 
FastEthernet0/0        10.10.10.1      YES manual up                    up
FastEthernet0/1        20.20.20.1      YES manual up                    up
 
Vlan1                  unassigned      YES unset  administratively down down

As you can see, there is only directly connected neighbours in the routing table of RouterA. RouterA do not know any other networks, also RouterD. There is no routing protocol configured on RouterA.

Firstly RouterA is configured like below with network commands under rip process.

RouterA(config)#router rip 
RouterA(config-router)#version 2
RouterA(config-router)#network 10.10.10.0
RouterA(config-router)#network 20.20.20.0

After this configuration, if we check the routing table, we will still see the same output. Because the other ends are not configured yet.

RouterA#show ip route 
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/30 is subnetted, 1 subnets
C       10.10.10.0 is directly connected, FastEthernet0/0
     20.0.0.0/30 is subnetted, 1 subnets
C       20.20.20.0 is directly connected, FastEthernet0/1

RIP configuration is done like below for RouterB.

RouterB(config)#router rip
RouterB(config-router)#version 2
RouterB(config-router)#network 10.10.10.0
RouterB(config-router)#network 30.30.30.0

After configuration of RouterB, we can see the rip routes in the routing table with R label.

RouterB(config-router)#do show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/30 is subnetted, 1 subnets
C       10.10.10.0 is directly connected, FastEthernet0/0
R    20.0.0.0/8 [120/1] via 10.10.10.1, 00:00:04, FastEthernet0/0
     30.0.0.0/30 is subnetted, 1 subnets
C       30.30.30.0 is directly connected, FastEthernet0/1

We can see the RIP route on RouterA also.

RouterA#show ip route 
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/30 is subnetted, 1 subnets
C       10.10.10.0 is directly connected, FastEthernet0/0
     20.0.0.0/30 is subnetted, 1 subnets
C       20.20.20.0 is directly connected, FastEthernet0/1
R    30.0.0.0/8 [120/1] via 10.10.10.2, 00:00:12, FastEthernet0/0

RIP configuration is done like below for RouterC.

RouterC(config)#router rip
RouterC(config-router)#version 2
RouterC(config-router)#network 20.20.20.0
RouterC(config-router)#network 40.40.40.0

After the configuration of RouterC, the routing table of RouterC is like below.

RouterC#show ip route 
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

R    10.0.0.0/8 [120/1] via 20.20.20.1, 00:00:08, FastEthernet0/1
     20.0.0.0/30 is subnetted, 1 subnets
C       20.20.20.0 is directly connected, FastEthernet0/1
R    30.0.0.0/8 [120/2] via 20.20.20.1, 00:00:08, FastEthernet0/1
     40.0.0.0/30 is subnetted, 1 subnets
C       40.40.40.0 is directly connected, FastEthernet0/0

RIP configuration is done like below for RouterD.

RouterD(config)#router rip 
RouterD(config-router)#version 2
RouterD(config-router)#network 40.40.40.0
RouterD(config-router)#network 30.30.30.0

After the configuration of all the routers for RIP, let’s check the routign table of the routers.

RouterA#show ip route 
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/30 is subnetted, 1 subnets
C       10.10.10.0 is directly connected, FastEthernet0/0
     20.0.0.0/30 is subnetted, 1 subnets
C       20.20.20.0 is directly connected, FastEthernet0/1
R    30.0.0.0/8 [120/1] via 10.10.10.2, 00:00:17, FastEthernet0/0
R    40.0.0.0/8 is possibly down, routing via 10.10.10.2, FastEthernet0/0

RouterB#show ip route 
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/30 is subnetted, 1 subnets
C       10.10.10.0 is directly connected, FastEthernet0/0
R    20.0.0.0/8 [120/1] via 10.10.10.1, 00:00:11, FastEthernet0/0
     30.0.0.0/30 is subnetted, 1 subnets
C       30.30.30.0 is directly connected, FastEthernet0/1
R    40.0.0.0/8 is possibly down, routing via 30.30.30.2, FastEthernet0/1

RouterC#show ip route 
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

R    10.0.0.0/8 [120/1] via 20.20.20.1, 00:00:10, FastEthernet0/1
     20.0.0.0/30 is subnetted, 1 subnets
C       20.20.20.0 is directly connected, FastEthernet0/1
R    30.0.0.0/8 [120/1] via 40.40.40.2, 00:00:12, FastEthernet0/0
     40.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
R       40.0.0.0/8 [120/3] via 20.20.20.1, 00:00:10, FastEthernet0/1
C       40.40.40.0/30 is directly connected, FastEthernet0/0

RouterD#show ip route 
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

R    10.0.0.0/8 [120/1] via 30.30.30.1, 00:00:22, FastEthernet0/1
R    20.0.0.0/8 [120/1] via 40.40.40.1, 00:00:21, FastEthernet0/0
     30.0.0.0/30 is subnetted, 1 subnets
C       30.30.30.0 is directly connected, FastEthernet0/1
     40.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
R       40.0.0.0/8 [120/4] via 40.40.40.1, 00:00:21, FastEthernet0/0
C       40.40.40.0/30 is directly connected, FastEthernet0/0

We can also check the “show ip protocols” output.

RouterA#show ip protocols 
Routing Protocol is "rip"
Sending updates every 30 seconds, next due in 22 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Redistributing: rip
Default version control: send version 2, receive 2
  Interface             Send  Recv  Triggered RIP  Key-chain
  FastEthernet0/0       2     2     
  FastEthernet0/1       2     2     
Automatic network summarization is in effect
Maximum path: 4
Routing for Networks:
	10.0.0.0
	20.0.0.0
Passive Interface(s):
Routing Information Sources:
	Gateway         Distance      Last Update
	10.10.10.2           120      00:00:12
Distance: (default is 120)

RouterC#show ip protocols 
Routing Protocol is "rip"
Sending updates every 30 seconds, next due in 16 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Redistributing: rip
Default version control: send version 2, receive 2
  Interface             Send  Recv  Triggered RIP  Key-chain
  FastEthernet0/1       2     2     
  FastEthernet0/0       2     2     
Automatic network summarization is in effect
Maximum path: 4
Routing for Networks:
	20.0.0.0
	40.0.0.0
Passive Interface(s):
Routing Information Sources:
	Gateway         Distance      Last Update
	20.20.20.1           120      00:00:03
	40.40.40.2           120      00:00:03
Distance: (default is 120)

The RIP configuration in running-config is like bellow:

RouterA#show running-config 
!
interface Vlan1
 no ip address
 shutdown
!
router rip
 version 2
 network 10.0.0.0
 network 20.0.0.0
!
ip classless
!

In this article, we focused on the configuration of RIP protocol with packet tracer.

You can DOWNLOAD the Packet Tracer example with .pkt format HERE.



************************************************************
WouLd YoU LiKe To Learn How to Use PAcket TraceR and PracTice CCNA LAbs
on PaCKet TrAcEr??? Here is My Courses on UDemY!!
CISCO PACKET TRACER HOW TO GUIDE
CISCO PACKET TRACER CCNA LABS ADVENTURE 1
CISCO PACKET TRACER CCNA LABS ADVENTURE 2
************************************************************

You can download “Packet Tracer” in Tools section.

Routing with RIP – Part 1
Routing with RIP – Part 2 (RIP Configuration With Packet Tracer)

You can check the other Packet Tracer Examples below:

Common Cisco Router Configuration Example on Packet Tracer
Router DHCP Configuration Example on Packet Tracer
VTP Configuration Example on Packet Tracer
VLAN Configuration Example on Packet Tracer
STP Configuration Example on Packet Tracer
BGP Configuration Example on Packet Tracer
Port Security Configuration Example on Packet Tracer
RIP Configuration Example on Packet Tracer
CDP Configuration Example on Packet Tracer
OSPF Area Types Example on Packet Tracer (Standard and Backbone Areas)
OSPF External Routes Example on Packet Tracer
OSPF Area Types Example on Packet Tracer (Stub, NSSA, Totally Stubby, Totally NSSA Areas)

Youn can join OUR Facebook Group with the below links!!!

You can Reach Our "CCNA Lab Courses with Packet Tracer" on Udemy.!!!
cisco-packet-tracer-ccna-adventure-1- cisco-packet-tracer-ccna-adventure-2-



About the Author
Gokhan Kosem is a telecommunation and network engineer. His ambition to IP networks and end-to-end system installation made him to prepare this web-site. By sharing his experiences about various networking protocols beside different system installation experiences and Cisco, Juniper, Alcatel-Lucent devices configurations, he is aimed to be helpful for his collegues in all over the world. He is currently lives in Istanbul, Turkey.

Leave a Reply


Copy Protected by Chetan's WP-Copyprotect.