Huawei Router Interface Configuration

huawei-router-interface-configuration

Huawei Router Interface Configuration

 

Huawei Router Interface Configuration is one of the first configuration that Junior Network Engineers learn on Huawei Routers. Here, we will show how to configure Huawei Router Interfaces with given IP addresses.

 


You can test youself with Huawei HCIA Questions Page.


 

For our example, we will use the below simple topology.

 

huawei-router-interface-configuration

 

 


You can download this configuration on Huawei eNSP Labs Page.


 

As you can see above, there are two types interfaces. These are :

  • Pyhsical Interfaces
  • Loopback Interfaces

 

In this configuration example, we have 1 loopback and 1 physical interface per router. Physical interface configuration will be done for the communication of two router. Loopback interface configuration is done for other special activities.Here, we will also configure it only to show you that it is not different than a physical interface configuration.

 

Let’s start the configuration with Router A.

 

In Router A, firstly we will con figure Gigabit Ethernet 0/0/0 interface IP Address with its Subnet Mask. After this, we will open the port. Because by default router ports are shutdown. We will use “undo shutdown” command to open the port.

 

<Huawei-RouterA> system-view
[Huawei-RouterA] interface GigabitEthernet 0/0/0
[Huawei-RouterA-GigabitEthernet0/0/0] ip address 192.168.0.1  255.255.255.0
[Huawei-RouterA-GigabitEthernet0/0/0] undo shutdown
[Huawei-RouterA-GigabitEthernet0/0/0] quit

 

The second interface configuration on Router A will be Loopback 0 configuration. Again, we will configure IP Address and Subnet Mask. We can configure Subnet Mask with long versions like (255.255.255.255) or short versions (32).

 

[Huawei-RouterA] interface Loopback 0
[Huawei-RouterA-Loopback0] ip address 10.10.10.10 32
[Huawei-RouterA-Loopback0] quit

 

Now, it is time to configure Router B. We will do the same configuration steps for Router B too. Only the IP Addresses will change.

 

< Huawei-RouterB> system-view
[Huawei-RouterB] interface GigabitEthernet 0/0/0
[Huawei-RouterB-GigabitEthernet0/0/0] ip address 192.168.0.2  255.255.255.0
[Huawei-RouterB-GigabitEthernet0/0/0] undo shutdown
[Huawei-RouterB-GigabitEthernet0/0/0] quit

 

Back to: HCNA > Static Routing

Leave a Reply

Your email address will not be published. Required fields are marked *

Contact

  • info@ipcisco.com
IPCisco is the Winner! “Best Certification Study Journey of 2019!”

Cisco-ITBlogAwards-2019-Winner-IPCisco-k

HCNA