BGP Configuration Example

Basic-BGP-Topology

Packet Tracer BGP Configuration Example

To understand BGP (Border Gateway Protocol) better, we will make a basic Packet Tracer BGP Configuration example. Because of the limited numbers of commands available on Packet Tracer, we will practice a very basic configuration for our BGP Config Example. Beside this, I will add some additional cofiguration steps that is needed for IBGP but we can not config ure on Packet Tracer.


In the configuration we will use two AS (Autonomous System) with 3 routers for each. We will use the Private AS block (64512 to 65535) for this configuration, but in internet public AS numbers are used.


You can DOWNLOAD Packet Tracer example with .pkt format HERE.


DOWNLOAD all the Packet Tracer examples with .pkt format in Packet Tracer Labs section.


You can also test yourself with BGP Tests and Questions.


The topology that we will be used for our BGP Config is below:

basic bgp configuration example topology
 

BGP Configuration Topology

For Packet Tracer BGP Configuration, firstly we need to configure the IP addresses of interfaces as other examples. To do this, as a better network engineering rule, firstly make your IP plan or, use the existing one. Acording to my basic IP plan, I used the below IPs for my interfaces.

Interfaces IP Addresses
1.1.1.1
2.2.2.2
10.0.0.1
10.0.0.2
20.0.0.1
20.0.0.2
30.0.0.1
30.0.0.2
40.0.0.1
40.0.0.2
50.0.0.1
50.0.0.2

Interface Configurations for Packet Tracer BGP Configuration

RouterA1 Interface Configuration

RouterA1(config)# interface loopback 0
RouterA1(config-if)# ip address 1.1.1.1 255.255.255.255
RouterA1(config-if)# no shutdown
RouterA1(config-if)# exit
RouterA1(config)# interface gigabitEthernet 0/0
RouterA1(config-if)# ip address 10.0.0.1 255.255.255.0
RouterA1(config-if)# no shutdown
RouterA1(config-if)# exit
RouterA1(config)# interface gigabitEthernet 0/1
RouterA1(config-if)# ip address 20.0.0.1 255.255.255.0
RouterA1(config-if)# no shutdown
RouterA1(config)# interface gigabitEthernet 0/2
RouterA1(config-if)# ip address 30.0.0.1 255.255.255.0
RouterA1(config-if)# no shutdown

RouterB1 Interface Configuration

RouterB1(config)# interface loopback 0
RouterB1(config-if)# ip address 2.2.2.2 255.255.255.255
RouterB1(config-if)# no shutdown
RouterB1(config-if)# exit
RouterB1(config)# interface gigabitEthernet 0/0
RouterB1(config-if)# ip address 10.0.0.2 255.255.255.0
RouterB1(config-if)# no shutdown
RouterB1(config-if)# exit
RouterB1(config)# interface gigabitEthernet 0/1
RouterB1(config-if)# ip address 40.0.0.1 255.255.255.0
RouterB1(config-if)# no shutdown
RouterB1(config-if)# exit
RouterB1(config)# interface gigabitEthernet 0/2
RouterB1(config-if)# ip address 50.0.0.1 255.255.255.0
RouterB1(config-if)# no shutdown

RouterA2 Interface Configuration

RouterA2(config)# interface gigabitEthernet 0/1
RouterA2(config-if)# ip address 20.0.0.2 255.255.255.0
RouterA2(config-if)# no shutdown

RouterA3 Interface Configuration

RouterA3(config)# interface gigabitEthernet 0/2
RouterA3(config-if)# ip address 30.0.0.2 255.255.255.0
RouterA3(config-if)# no shutdown

RouterB2 Interface Configuration

RouterB2(config)# interface gigabitEthernet 0/1
RouterB2(config-if)# ip address 40.0.0.2 255.255.255.0
RouterB2(config-if)# no shutdown

RouterB3 Interface Configuration

RouterB3(config)# interface gigabitEthernet 0/2
RouterB3(config-if)# ip address 50.0.0.2 255.255.255.0
RouterB3(config-if)# no shutdown

BGP Configurations for Packet Tracer BGP Configuration

The exact important point of BGP Config is here. The configuration made in this part, is for the BGP.

As I said before, because of the Packet Tracer ‘s command limit, in the configuration file, th IBGP parts are not configured, but writen here (ibgp neighbourship and route reflector commands).

RouterA1(config)# router bgp 64600
RouterA1(config-router)# neighbor 10.0.0.2 remote-as 64700
RouterA1(config-router)# neighbor 20.0.0.2 remote-as 64600
RouterA1(config-router)# neighbor 30.0.0.2 remote-as 64600
RouterA1(config-router)# neighbor 20.0.0.2 route-reflector-client
RouterA1(config-router)# neighbor 30.0.0.2 route-reflector-client
RouterA1(config-router)# network 20.0.0.0 mask 255.255.255.0
RouterA1(config-router)# network 30.0.0.0 mask 255.255.255.0

You can also test yourself with BGP Tests and Questions.


Lesson tags: BGP, cisco packet tracer, routing
Back to: CCIE Enterprise Infrastructure > BGP

Leave a Reply

Your email address will not be published. Required fields are marked *

CCIE Enterprise Infrastructure

Collapse
Expand