DTP and VLAN Frame Tagging protocols ISL, dot1.q

vlan frame tagging protocols

VLAN Frame Tagging Protocols (ISL and dot1.q)

In this lesson, we will learn VLAN Frame Tagging Protocols detailly. In the next lessons, you can also check Cisco VLAN Configuration Examples. What are these VLAN Frame Tagging Protocols? Let’s see each of them.

 

There are two types of frame tagging protocols. These are :

  • ISL (Inter-Switch Link)
  • dot1Q (IEEE 802.1Q)

 

These VLAN Frame Tagging Protocols can be configured manually or negotiated by DTP (Dynamic Trunking Protocol)DTP was developed by Cisco and it is a Cisco proprietary protocol. So, DTP can be used only on Cisco switches.

 

Now, let’s see each of these frame tagging protocols one by one.

 


 

VLAN Tagging: ISL (Cisco Inter-Switch Link)

ISL (Inter-Switch Link) is a Cisco proprietary frame tagging protocol and it is not supported on new Cisco devices. But as an old protocol, it is good to know ISL.

 

ISL encapsulates the frame with a header (26 bytes) and a trailer (4 bytes). So, ISL increases the size of a frame 30 bytes. ISL support 1000 VLANs on a trunk port.

 

We can configure ISL on Cisco switches with the help of “switchport trunk encapsulation isl” command.

 

Switch(config)# interface fa0/0

Switch(config-if)# switchport trunk encapsulation isl

 

You can find ISL header & trailer in the below ISL VLAN Tagging example.

 

ISL vlan tagging protocol

ISL Header & Trailer

 


VLAN Tagging: Dot1Q (IEEE 802.1Q)

Dot1Q (IEEE 802.1Q) is the industry standard VLAN Tagging Protocol. So, with this frame tagging protocol, you can trunk different vendors’ switches each other.

 

Dot1Q modifies the layer-2 header and add 4-byte VLAN tag into it. Because of this process, the frame CRC value is calculated again. Dot1.q support 4096 VLANs on a trunk.

 

We can configure Dot1.Q on Cisco switches with the help of “switchport trunk encapsulation dot1.q” command like below:

 

Switch(config)# interface fa0/0

Switch(config-if)# switchport trunk encapsulation dot1.q

 

 

The normal frame size is 1514 bytes. With ISL, this value increase 30 bytes and the frame become giant to other vendor’s switches. But with dot1.q, the frame size become 1514 to 1518. And this value is supported by all other vendors’ switches.

 

You can find Dot1.Q Header example below:

 

802.1Q vlan tagging protocol

Dot1.Q Header

 

The configuration of VLAN Tagging Protocols must be same at both ends on switches.

 

To do frame tagging protocol selection, we can also use DTP (Dynamic Trunking Protocol). Here, if there are old Cisco devices at both ends and they both support ISL and dot1.q, ISL is preferred.

 

vlan frame tagging protocols, ISL and Dot1q
VLAN Frame Tagging Protocols, ISL and Dot1q
 


 

DTP (Dynamic Trunking Protocol)

Trunking in Cisco switches can be configured statically or dynamically. In static mode, the interfaces must be configured as trunk manually. In dynamic mode, a specific protocol, DTP (Dynamic Trunking Protocol) is used for this job.

 

DTP (Dynamic Trunking Protocol) is a Cisco proprietary trunk negotiation protocol. So, we can use DTP only between two Cisco switches. With DTP, directly connected switches determine the interface roles, as trunk or not. To do this, DTP uses different modes.

 

There are different DTP modes that can be configured on interfaces. These DTP modes put an interface in a trunk state immediately or they negotiate with the other end interface on the other switch.

 

So, what are these DTP modes? These are given below:

  • Access
  • Trunk
  • Dynamic Auto
  • Dynamic Desirable
  • Nonegotiate

 

Now, let’s learn the roles of these DTP modes one by one.

 

Access: Access mode puts the interface in a permanent nontrunking, access mode. Even if the other end is in trunking mode. We can configure access mode like below:

 

Switch(config-if)# switchport mode access

 

Trunk: Trunk mode puts the interface in a permanent trunking mode. Even if the other end is not in trunking mode.

 

Switch(config-if)# switchport mode trunk

 

Dynamic Auto: Dynamic Auto mode puts interface ready to be a trunk if the other end is in trunk or dynamic desirable mode. It is a passive mode. It does not actively attempt to convert the link to a trunk. Dynamic Auto is the default mode of the recent Cisco switches.

 

Switch(config-if)# switchport mode dynamic auto

 

Dynamic Desirable: Dynamic Desirable puts interface ready to be a trunk if the other end is in trunk, dynamic desirable or dynamic auto mode. It is an active mode. It actively attempts to convert the link to a trunk, if the other end in trunk, dynamic auto and dynamic desirable modes. Oldest Cisco switches was in dynamic desirable mode by default.

 

Switch(config-if)# switchport mode dynamic desirable

 

Nonegotiate: Nonegotiate mode prevents sending DTP frames. This command is used after configuring the switch as access or trunk. With nonegotiate mode, you are deciding the mode and then you are saying that “do not negotiate about this”.

 

Switch(config-if)# switchport nonegotiate

 

As a summary, you can check the below shape which shows both manual trunk configuration and the function of different DTP modes.

dtp-and-trunk-modes-ipcisco

DTP & Trunk Modes

dtp-and-trunking-modes-ipcisco

DTP & Trunk Modes

 

Lesson tags: VLANs, vlan tagging, isl, dot1q
Back to: CCNA 200-301 > VLANs

Leave a Reply

Your email address will not be published.

IPCisco is the Winner of 2019 “Best Certification Study Journey” Category! We are also Finalist of 2020 & 2021 in Cisco IT Blog Awards!

Cisco-ITBlogAwards-2019-Winner-IPCisco-k
ITBlogAwards_2020_Badge-Finalist-BestCertStudy-ipcisco
ITBlogAwars-2021-ipcisco

CCNA 200-301

Collapse
Expand
IPCisco on Social Media!